diff options
author | Linux-cpp-lisp <1473644+Linux-cpp-lisp@users.noreply.github.com> | 2021-11-17 15:57:44 -0500 |
---|---|---|
committer | Linux-cpp-lisp <1473644+Linux-cpp-lisp@users.noreply.github.com> | 2021-11-17 15:57:44 -0500 |
commit | ce73094b493c2fb12e113f1f729f7c876c447715 (patch) | |
tree | 2792a0826767fcdc5da3c48162c8379382dd0480 /setup.py | |
parent | f658af9055647685c7713c36de4905f34e4d8508 (diff) |
Refactor and bump version
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -1,6 +1,13 @@ from setuptools import setup, find_packages +from pathlib import Path + +# see https://packaging.python.org/guides/single-sourcing-package-version/ +version_dict = {} +with open(Path(__file__).parents[0] / "torch_runstats/_version.py") as fp: + exec(fp.read(), version_dict) +version = version_dict["__version__"] +del version_dict -__version__ = '0.2' url = 'https://github.com/fadel/pytorch_ema' download_url = '{}/archive/{}.tar.gz'.format(url, __version__) @@ -10,7 +17,7 @@ tests_require = [] setup( name='torch_ema', - version=__version__, + version=version, description='PyTorch library for computing moving averages of model parameters.', author='Samuel G. Fadel', author_email='samuelfadel@gmail.com', |